10/27/2025 Vision Production Limited Outage

Incident Report for Decisiv SRM

Resolved

The issue has been resolved and normal service has been restored.
Posted Oct 27, 2025 - 20:41 EDT

Investigating

We are aware of the errors that users were met with when attempting to access the Vision Production environment. Our team is currently investigating and will update the Status Page as we work towards a resolution.
Posted Oct 27, 2025 - 17:35 EDT
This incident affected: Case (Provider) and Vision.