10/20/2025 Case & Insite Notification Delays

Incident Report for Decisiv SRM

Resolved

The issue has been resolved and normal service has been restored.
Posted Oct 20, 2025 - 23:38 EDT

Monitoring

We are currently aware of a delay in notifications produced from the Case and Insite products as a result of the widespread service availability issues reported by AWS. As these issues resolve you should notice these delays subsiding.

We'll continue to monitor the situation moving forward, follow the status page for further updates.
Posted Oct 20, 2025 - 14:36 EDT
This incident affected: Case (Provider, Fleet) and Insite.